$re = '/(?<=\\\\)[^\\\\]+sav/m';
$str = 'C:\\Users\\\\...\\\\Standard Loadflows Seq and Dyn PSSEv34 - 2019-02-20\\\\WinterLo-20180729-043047-34-SystemNormal\\\\WinterLo-20180729-043047-34-SystemNormal.sav';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);