re = /(?<=\\)[^\\]+sav/m
str = 'C:\\Users\\\\...\\\\Standard Loadflows Seq and Dyn PSSEv34 - 2019-02-20\\\\WinterLo-20180729-043047-34-SystemNormal\\\\WinterLo-20180729-043047-34-SystemNormal.sav'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end