#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?(DEFINE)(?<urlPart>[^\\\s]+))\\\\(?&urlPart)\\(?&urlPart)\\\K(?&urlPart)"
Local $sString = "### Positive matches" & @CRLF & _
"\\10.20.3.23\S$\COMPANY_NAME\Main_5e08a942f39a430db0b081736a3f1881\C_VOL-b002.spf" & @CRLF & _
"\\localhost\part1\selectMe" & @CRLF & _
"\\a\b\select-me but not me" & @CRLF & _
"\\a\b\select_me\c\d\e.abc more text here" & @CRLF & _
"This is the link \\a\b\select-me\c\d\e.abc inside a longer string" & @CRLF & _
"\\a\b\select_me_from_1st_link\c.abc \\a\b\selectMeFrom2ndLink\c.abc" & @CRLF & _
"" & @CRLF & _
"## Negative matches" & @CRLF & _
"\a\b\c\dontSelectMe\e\f" & @CRLF & _
"\\\\dont-select-me or me" & @CRLF & _
"\\a \b \dont_select_me \c \d \e.abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")