use strict;
my $str = '### Positive matches
\\\\10.20.3.23\\S$\\COMPANY_NAME\\Main_5e08a942f39a430db0b081736a3f1881\\C_VOL-b002.spf
\\\\localhost\\part1\\selectMe
\\\\a\\b\\select-me but not me
\\\\a\\b\\select_me\\c\\d\\e.abc more text here
This is the link \\\\a\\b\\select-me\\c\\d\\e.abc inside a longer string
\\\\a\\b\\select_me_from_1st_link\\c.abc \\\\a\\b\\selectMeFrom2ndLink\\c.abc
## Negative matches
\\a\\b\\c\\dontSelectMe\\e\\f
\\\\\\\\dont-select-me or me
\\\\a \\b \\dont_select_me \\c \\d \\e.abc';
my $regex = qr/(?(DEFINE)(?<urlPart>[^\\\s]+))\\\\(?&urlPart)\\(?&urlPart)\\\K(?&urlPart)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}