const regex = /(?(DEFINE)(?<urlPart>[^\\\s]+))\\\\(?&urlPart)\\(?&urlPart)\\\K(?&urlPart)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)(?<urlPart>[^\\\\\\s]+))\\\\\\\\(?&urlPart)\\\\(?&urlPart)\\\\\\K(?&urlPart)', 'gm')
const str = `### Positive matches
\\\\10.20.3.23\\S\$\\COMPANY_NAME\\Main_5e08a942f39a430db0b081736a3f1881\\C_VOL-b002.spf
\\\\localhost\\part1\\selectMe
\\\\a\\b\\select-me but not me
\\\\a\\b\\select_me\\c\\d\\e.abc more text here
This is the link \\\\a\\b\\select-me\\c\\d\\e.abc inside a longer string
\\\\a\\b\\select_me_from_1st_link\\c.abc \\\\a\\b\\selectMeFrom2ndLink\\c.abc
## Negative matches
\\a\\b\\c\\dontSelectMe\\e\\f
\\\\\\\\dont-select-me or me
\\\\a \\b \\dont_select_me \\c \\d \\e.abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}