import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*(^[a-zA-Z0-9]{12}$))(?=.*([a-zA-Z]{1,}))(?=.*([0-9]{1,}))";
final String string = "123456789012\n"
+ "111111111111\n"
+ "abcdefghijkl\n"
+ "ABCDEFGHIJKL\n"
+ " ABCDEFGHIJKL\n"
+ "abcdef\n"
+ "abcd12AS\n"
+ "a\n"
+ "1\n"
+ "A\n\n"
+ "abcde12345yz\n"
+ "ABCDE12345YZ\n"
+ "abcd1234ABCD\n"
+ "1234abcd12AZ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}