const regex = /(?=.*(^[a-zA-Z0-9]{12}$))(?=.*([a-zA-Z]{1,}))(?=.*([0-9]{1,}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*(^[a-zA-Z0-9]{12}$))(?=.*([a-zA-Z]{1,}))(?=.*([0-9]{1,}))', 'gm')
const str = `123456789012
111111111111
abcdefghijkl
ABCDEFGHIJKL
ABCDEFGHIJKL
abcdef
abcd12AS
a
1
A
abcde12345yz
ABCDE12345YZ
abcd1234ABCD
1234abcd12AZ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}