import Foundation
let pattern = #"(?=.*(^[a-zA-Z0-9]{12}$))(?=.*([a-zA-Z]{1,}))(?=.*([0-9]{1,}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123456789012
111111111111
abcdefghijkl
ABCDEFGHIJKL
ABCDEFGHIJKL
abcdef
abcd12AS
a
1
A
abcde12345yz
ABCDE12345YZ
abcd1234ABCD
1234abcd12AZ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)