const regex = /^(?:\+?44|(?!\s*4\s*4))(?:\s*\d){9,11}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+?44|(?!\\s*4\\s*4))(?:\\s*\\d){9,11}$', 'gm')
const str = `TRUE:
123456789
1234567890
12345678901
+4407925134567
07925134567
FALSE:
+44079251345672
> 123456789012
+440798444
123456789112
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}