re = /^(?:\+?44|(?!\s*4\s*4))(?:\s*\d){9,11}$/m
str = 'TRUE:
123456789
1234567890
12345678901
+4407925134567
07925134567
FALSE:
+44079251345672
> 123456789012
+440798444
123456789112
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end