import re
regex = re.compile(r"^(?:\+?44|(?!\s*4\s*4))(?:\s*\d){9,11}$", flags=re.MULTILINE)
test_str = ("TRUE:\n"
"123456789\n"
"1234567890\n"
"12345678901\n"
"+4407925134567\n"
"07925134567\n\n"
"FALSE:\n"
"+44079251345672\n"
" > 123456789012\n"
"+440798444\n"
"123456789112\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")