using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"‘[^‘]{250,}[.,?!]’";
string input = @"‘So this is a short quote’ ‘This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote.’";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}