re = /‘[^‘]{250,}[.,?!]’/m
str = '‘So this is a short quote’ ‘This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote.’'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end