package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)‘[^‘]{250,}[.,?!]’`)
var str = `‘So this is a short quote’ ‘This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote. This is a long quote.’`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}