package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?:[^)(]|\((?:[^)(]|\((?:[^)(]|\([^)(]*\))*\))*\))*\)`)
var str = `some text(text here(possible text)text(possible text(more text)))end text
text (l0 (l1 (l2)) l0 (l1 (l2 (l3))) (l1)) text (l0 (l1) (l1 ((l3) l2)) (l1)) text
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}