// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((?:[^)(]|\((?:[^)(]|\((?:[^)(]|\([^)(]*\))*\))*\))*\)").unwrap();
let string = "some text(text here(possible text)text(possible text(more text)))end text
text (l0 (l1 (l2)) l0 (l1 (l2 (l3))) (l1)) text (l0 (l1) (l1 ((l3) l2)) (l1)) text
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}