import Foundation
let pattern = #"\((?:[^)(]|\((?:[^)(]|\((?:[^)(]|\([^)(]*\))*\))*\))*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
some text(text here(possible text)text(possible text(more text)))end text
text (l0 (l1 (l2)) l0 (l1 (l2 (l3))) (l1)) text (l0 (l1) (l1 ((l3) l2)) (l1)) text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)