use strict;
my $str = '"address":"http://test/services/user/v1/deleteUser/342ad-123m4-r43rm-144dgdg
"address":"http://test/services/user/v2/deleteUser/delete/342ad-123m4-r43rm-144dgdg
"address":"http://test/services/user/v2/deleteUser';
my $regex = qr/\"address\":\"(?<uri>https*:\/\/[^\/]+\/[^\/]+\/[^\/]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}