import Foundation
let pattern = #"\"address\":\"(?<uri>https*:\/\/[^\/]+\/[^\/]+\/[^\/]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"address":"http://test/services/user/v1/deleteUser/342ad-123m4-r43rm-144dgdg
"address":"http://test/services/user/v2/deleteUser/delete/342ad-123m4-r43rm-144dgdg
"address":"http://test/services/user/v2/deleteUser
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)