$re = '/\"address\":\"(?<uri>https*:\/\/[^\/]+\/[^\/]+\/[^\/]+)/m';
$str = '"address":"http://test/services/user/v1/deleteUser/342ad-123m4-r43rm-144dgdg
"address":"http://test/services/user/v2/deleteUser/delete/342ad-123m4-r43rm-144dgdg
"address":"http://test/services/user/v2/deleteUser';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);