re = /<div id="PageTitle">.+?<\/div>/
str = '<div id="PageTitle"> Page title as a string </div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end