# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/length\(([a-zA-Z]+)\)/LEN($1)/gm;t' <<< "select *,length(devise) lendevise,length(marche) lenmarche,length(nature) lennature from tableX where nseq='0'"