$re = '/length\(([a-zA-Z]+)\)/m';
$str = 'select *,length(devise) lendevise,length(marche) lenmarche,length(nature) lennature from tableX where nseq=\'0\'';
$subst = "LEN($1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;