const regex = /length\(([a-zA-Z]+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('length\\(([a-zA-Z]+)\\)', 'gm')
const str = `select *,length(devise) lendevise,length(marche) lenmarche,length(nature) lennature from tableX where nseq='0'`;
const subst = `LEN($1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);