using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Serial\sNumber.*?(?=\w)(\w+)";
string input = @"blah: asdf
blah: asdf
Serial Number: 1234ABCD
blah asdf
blah asdf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}