$re = '/Serial\sNumber.*?(?=\w)(\w+)/';
$str = 'blah: asdf
blah: asdf
Serial Number: 1234ABCD
blah asdf
blah asdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);