re = /Serial\sNumber.*?(?=\w)(\w+)/
str = 'blah: asdf
blah: asdf
Serial Number: 1234ABCD
blah asdf
blah asdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end