#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]{1,3}(?:.[0-9]{3})*\,[0-9]+(?=\s?€)"
Local $sString = " <a href="blahblahblah-dynamic" class="blahblahblah-dynamic" " & @CRLF & _
" title="blahblahblah-dynamic">2.550,00 €</a>1000 € 900 € 5000 € ......"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")