using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]{1,3}(?:.[0-9]{3})*\,[0-9]+(?=\s?€)";
string input = @" <a href=""blahblahblah-dynamic"" class=""blahblahblah-dynamic""
title=""blahblahblah-dynamic"">2.550,00 €</a>1000 € 900 € 5000 € ......";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}