$re = '/[0-9]{1,3}(?:.[0-9]{3})*\,[0-9]+(?=\s?€)/m';
$str = ' <a href="blahblahblah-dynamic" class="blahblahblah-dynamic"
title="blahblahblah-dynamic">2.550,00 €</a>1000 € 900 € 5000 € ......';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);