import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<Instrument>[A-Z]+)(?P<Year>\\d{2})(?P<month>\\d{1}|[A-Z]+)(?P<date>\\d{2})?(?P<strike>\\d{5})(?P<CEorPE>[A-Z]+)";
final String string = "NIFTY2431322000PE\n"
+ "NIFTY24DEC22000PE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}