import re
regex = re.compile(r"(?P<Instrument>[A-Z]+)(?P<Year>\d{2})(?P<month>\d{1}|[A-Z]+)(?P<date>\d{2})?(?P<strike>\d{5})(?P<CEorPE>[A-Z]+)", flags=re.MULTILINE)
test_str = ("NIFTY2431322000PE\n"
"NIFTY24DEC22000PE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")