use strict;
my $str = 'NIFTY2431322000PE
NIFTY24DEC22000PE';
my $regex = qr/(?P<Instrument>[A-Z]+)(?P<Year>\d{2})(?P<month>\d{1}|[A-Z]+)(?P<date>\d{2})?(?P<strike>\d{5})(?P<CEorPE>[A-Z]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}