import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!$)(?P<real>(?P<sign1>[+-]?)(?P<number1>\\d+(?:\\.\\d+)?))?(?:(?P<imag>(?P<sign2>[+-]?)(?P<number2>\\d+(?:\\.\\d+)?j)))?$";
final String string = "1+12j\n"
+ "12+18j\n"
+ "-14+45j\n"
+ "54\n"
+ "-87j";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}