const regex = new RegExp('^(?!$)(?P<real>(?P<sign1>[+-]?)(?P<number1>\\d+(?:\\.\\d+)?))?(?:(?P<imag>(?P<sign2>[+-]?)(?P<number2>\\d+(?:\\.\\d+)?j)))?$', 'gm')
const str = `1+12j
12+18j
-14+45j
54
-87j`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}