re = /^(?!$)(?P<real>(?P<sign1>[+-]?)(?P<number1>\d+(?:\.\d+)?))?(?:(?P<imag>(?P<sign2>[+-]?)(?P<number2>\d+(?:\.\d+)?j)))?$/m
str = '1+12j
12+18j
-14+45j
54
-87j'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end