import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(postgresql|postgres):\\/\\/((?:[^:@]*)(?::[^@]*)?@{0,1})?(?<server>[^\\/\\?]+)\\b";
final String string = "postgresql://localhost\n"
+ "postgresql://localhost:5433\n"
+ "postgresql://localhost/mydb\n"
+ "postgresql://user@localhost\n"
+ "postgresql://user:secret@localhost\n"
+ "postgresql://other@localhost/otherdb?connect_timeout=10&application_name=myapp\n"
+ "postgresql://host1:123,host2:456/somedb?application_name=myapp\n"
+ "postgres://myuser:mypassword@192.168.0.100:5432/mydatabase\n"
+ "postgresql://192.168.0.100/mydb\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}