# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(postgresql|postgres):\/\/((?:[^:@]*)(?::[^@]*)?@{0,1})?(?<server>[^\/\?]+)\b"
test_str = ("postgresql://localhost\n"
"postgresql://localhost:5433\n"
"postgresql://localhost/mydb\n"
"postgresql://user@localhost\n"
"postgresql://user:secret@localhost\n"
"postgresql://other@localhost/otherdb?connect_timeout=10&application_name=myapp\n"
"postgresql://host1:123,host2:456/somedb?application_name=myapp\n"
"postgres://myuser:mypassword@192.168.0.100:5432/mydatabase\n"
"postgresql://192.168.0.100/mydb\n\n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.