#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)HARRY((?:(?:(?!HARRY|DIVISION 3).|[\r\n])*?)DIVISION 3)"
Local $sString = "S3007/0011" & @CRLF & _
"20150590824" & @CRLF & _
"HARRY MOSES" & @CRLF & _
"F" & @CRLF & _
"32" & @CRLF & _
"DIVISION 4" & @CRLF & _
"CIV-'F' HIST-'D' GEO-'F' KISW-'D' ENGL-'D' PHY-'F' CHEM-'F' BIO-'F' B/MATH-'F' " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"S3007/0012" & @CRLF & _
"20151514797" & @CRLF & _
"HARRY MORGAN" & @CRLF & _
"F" & @CRLF & _
"26" & @CRLF & _
"DIVISION 3" & @CRLF & _
"CIV-'D' HIST-'C' GEO-'D' KISW-'C' ENGL-'C' PHY-'F' CHEM-'F' BIO-'D' B/MATH-'F' " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"S3007/0013" & @CRLF & _
"20151514798" & @CRLF & _
"HAPPINESS DEOGRATIAS" & @CRLF & _
"F" & @CRLF & _
"34" & @CRLF & _
"DIVISION 0" & @CRLF & _
"CIV-'F' HIST-'F' GEO-'F' KISW-'D' ENGL-'F' PHY-'F' CHEM-'F' BIO-'F' B/MATH-'F"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")