const regex = /HARRY((?:(?:(?!HARRY|DIVISION 3).|[\r\n])*?)DIVISION 3)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('HARRY((?:(?:(?!HARRY|DIVISION 3).|[\\r\\n])*?)DIVISION 3)', 'gm')
const str = `S3007/0011
20150590824
HARRY MOSES
F
32
DIVISION 4
CIV-'F' HIST-'D' GEO-'F' KISW-'D' ENGL-'D' PHY-'F' CHEM-'F' BIO-'F' B/MATH-'F'
S3007/0012
20151514797
HARRY MORGAN
F
26
DIVISION 3
CIV-'D' HIST-'C' GEO-'D' KISW-'C' ENGL-'C' PHY-'F' CHEM-'F' BIO-'D' B/MATH-'F'
S3007/0013
20151514798
HAPPINESS DEOGRATIAS
F
34
DIVISION 0
CIV-'F' HIST-'F' GEO-'F' KISW-'D' ENGL-'F' PHY-'F' CHEM-'F' BIO-'F' B/MATH-'F`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}