import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "HARRY((?:(?:(?!HARRY|DIVISION 3).|[\\r\\n])*?)DIVISION 3)";
final String string = "S3007/0011\n"
+ "20150590824\n"
+ "HARRY MOSES\n"
+ "F\n"
+ "32\n"
+ "DIVISION 4\n"
+ "CIV-'F' HIST-'D' GEO-'F' KISW-'D' ENGL-'D' PHY-'F' CHEM-'F' BIO-'F' B/MATH-'F' \n\n\n"
+ "S3007/0012\n"
+ "20151514797\n"
+ "HARRY MORGAN\n"
+ "F\n"
+ "26\n"
+ "DIVISION 3\n"
+ "CIV-'D' HIST-'C' GEO-'D' KISW-'C' ENGL-'C' PHY-'F' CHEM-'F' BIO-'D' B/MATH-'F' \n\n\n"
+ "S3007/0013\n"
+ "20151514798\n"
+ "HAPPINESS DEOGRATIAS\n"
+ "F\n"
+ "34\n"
+ "DIVISION 0\n"
+ "CIV-'F' HIST-'F' GEO-'F' KISW-'D' ENGL-'F' PHY-'F' CHEM-'F' BIO-'F' B/MATH-'F";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}