package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+,\s+\w+\s+\d+\,\s+\d+\s+at\s+\d+:\d+(pm|am)\s+\w{3}`)
var str = `Aritra Sinha Nirmal Friday, April 1, 2016 at 10:16pm EDT
Rahul Chowdhury Sunday, January 15, 2012 at 7:37pm EST`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}