$re = '/\w+,\s+\w+\s+\d+\,\s+\d+\s+at\s+\d+:\d+(pm|am)\s+\w{3}/';
$str = 'Aritra Sinha Nirmal Friday, April 1, 2016 at 10:16pm EDT
Rahul Chowdhury Sunday, January 15, 2012 at 7:37pm EST';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);