// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w+,\s+\w+\s+\d+\,\s+\d+\s+at\s+\d+:\d+(pm|am)\s+\w{3}").unwrap();
let string = "Aritra Sinha Nirmal Friday, April 1, 2016 at 10:16pm EDT
Rahul Chowdhury Sunday, January 15, 2012 at 7:37pm EST";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}