$re = '/^(?:(?:(?:\*)|(?:(?:[^<>()\[\],;:\s@\*]+(?:\.[^<>()\[\],;:\s@\*]+)*)|(?:\".+\"))+)@|\*@(?:\*\.)?)(?:(?:[^<>([\],;:\s@\*]+\.)+[^<>()[\],;:\s@\*]{2,})$/m';
$str = '# should match
*@*.open.ch
*@open.ch
pem@open.ch
pedro.mendez@open.ch
osag-mail-test@mail-test.opensystems.ch
this."is valid indeed #%&^".stupid@foo.bar
# should not match
*@*open.ch
foo@*.bar.com
lalal.com
@example.com
foo*@example.com
f*o@example.com
foo@ex*mple.com
foo@ex.*.ple.com
tst@@open.ch';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);