package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(Sam|Jim)\b`)
var str = `Hello, Jim.
I knew it was Sam! Sam why?!
Is your real name Samuel?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}