$re = '/\b(Sam|Jim)\b/m';
$str = 'Hello, Jim.
I knew it was Sam! Sam why?!
Is your real name Samuel?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);