re = /\b(Sam|Jim)\b/m
str = 'Hello, Jim.
I knew it was Sam! Sam why?!
Is your real name Samuel?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end