# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((tin)[[:blank:]]+(nóng)[[:blank:]]+24h)"
test_str = ("GIỚI THIỆU CHƯƠNG TRÌNH TRUYỀN HÌNH NGÀY MAI – THỨ HAI 12/10/2015\n"
"---\n"
"PTV xuất hiện : Quí khán giả thân mến, ngày mai thứ hai 12/10/2015, những nội dung chính trong chương trình TH của Đài PT&TH Tp Cần Thơ như sau :\n"
"* BUỔI SÁNG & TRƯA :\n"
"- 5H03’ Ca nhạc…\n"
"- 5H15’ Đồng cảm và sẻ chia (pl)\n"
"- 5H25’ (QC,QB các chương trình của Đài …) \n"
"- 5H30’ Thời sự Tp Cần Thơ\n"
"- 6H00’ Chuyên đề Dân số - Gia đình & Trẻ em\n"
"- 6H10’ ( Trailer về sốt xuất huyết)\n"
"- 6H15’ Phim tài liệu : NÔNG THÔN ỨNG PHÓ VỚI BIẾN ĐỔI KHÍ HẬU – T5 : \n"
"KHOA HỌC CÔNG NGHỆ GIÚP NÔNG DÂN THÍCH ỨNG BIẾN ĐỔI KHÍ HẬU (pl) \n"
"- 6H45’ Cẩm nang sống khỏe (197 –pl - Đay thao nhat)\n"
"- 7H00’ Làm chủ tay lái (39/15- pl - Nhường đường cho xe ưu tiên sao cho đúng )\n"
"- 7H05’ (Quảng cáo, QB các chương trình của Đài)\n"
"- 7H10’ Phim truyện VN : TÌNH NGƯỜI XỨ HOA– Tập 14/36 \n"
"- 7H55’ (Quảng cáo, QB các chương trình của Đài)\n"
"- 8H00’ Bản tin tiếng Anh (pl)\n"
"- 8H10’ Góc khuất (182- pl -Thay đổi để hòa hợp…)\n"
"- 8H40’ (Quảng cáo, QB các chương trình của Đài)\n"
"- 8H45’ Phim truyện TQ : QUÁN TRÀ VUI VẺ - P2 -Tập 19&20/50\n"
"- 10H35’ ( Qc, Qb các chương trình của Đài…)\n"
"- 10H40’ Alo bác sỹ (277- Viêm phần phụ )\n"
"- 10H50’ ( Qc, Qb các chương trình của Đài…)\n"
"- 11H00’ Chương trình 11.00\n"
"- 11H15’ (QC,QB các chương trình của Đài …)\n"
"- 11H20’ Phim truyện Ấn Độ : MỐI TÌNH KỲ LẠ - Tập 179&180/192\n"
"- 13H05’ (QC,QB …)\n"
" \n"
" \n\n"
"=>\n"
" \n\n\n\n\n\n\n\n\n\n\n"
"*BUỔI CHIỀU VÀ TỐI :\n"
"-13H10’ Vào bếp cùng khán giả (pl của ngày 09/10/2015)\n"
"-13H20’ (QC,QB các chương trình của Đài …)\n"
"-13H25’ Phim truyện ĐL : VÒNG XOÁY KIM TIỀN – Tập 137&138/400\n"
"-15H15’ (QC,QB các chương trình của Đài …)\n"
"-15H20’ Phim truyện VN : BÃO– Tập 1/40\n"
"-16H15’ Gõ cửa trái tim (198 – Những MV siêu dễ thương…)\n"
"-16H45’ (QC,QB các chương trình của Đài …)\n"
"-16H50’ Phim truyện TQ : THỜI NIÊN THIẾU BAO THANH THIÊN– P3 :\n"
" THIÊN MANG TRUYỀN KỲ – Tập 45\n"
"-17H40’ (QC,QB các chương trình của Đài …)\n"
"-17H45’ Phim Sitcom : TIỆM BÁNH HOÀNG TỬ BÉ - Tập 166\n"
"-17H55’ (QC,QB các chương trình của Đài …)\n"
"-18H00’ Chuyên đề Khoa học - Công nghệ & Môi trường\n"
"-18H10’ Cần thơ phố\n"
"-18H20’ Điểm tin thị trường\n"
"-18H25’ (QC,QB các chương trình của Đài …)\n"
"-18H30’ Thời sự Tp Cần Thơ /Dự báo thời tiết\n"
"-19H00’ (QC,QB các chương trình của Đài …)\n"
"-19H05’ Chuyện Bà Tám (297 –Bức tử rừng thông )\n"
"-19H15’ (QC,QB các chương trình của Đài …)\n"
"-19H20’ Phim truyện Indonesia : MƯU KẾ TÌNH YÊU – Tập 17&18/90\n"
"-21H05’ (QC,QB các chương trình của Đài …)\n"
"-21H10’ Phim truyện VN : BÃO –Tập 34/40\n"
"-22H00’ Món ngon mỗi ngày : GÀ CUỘN CẢI BÓ XÔI ĐÚT LÒ (pl)\n"
"-22H05’ Phim truyện VN : BÃO –Tập 35/40\n"
"-23H00’ (QC,QB các chương trình của Đài …)\n"
"-23H05’ Bản tin Thời sư TpCT \n"
"-23H15’ Bản tin thế giới\n"
"-23H25’ Bản tin tiếng Anh\n"
"-23H35’ Phim tài liệu : NÔNG THÔN ỨNG PHÓ VỚI BIẾN ĐỔI KHÍ HẬU – T6 : \n"
" CỘNG ĐỒNG TRONG ỨNG PHÓ BIẾN ĐỔI KHÍ HẬU\n"
"-00H05’ Phim truyện HQ : CUỘC CHIẾN HOÀNG CUNG – Tập 29/35\n"
"PTV xh trở lại : \n"
" Chương trình truyền hình của Đài PT&TH Tp Cần Thơ đến đây là hết, \n"
"Hẹn găp lại quí khán giả vào chương trình truyền hình sáng thứ hai.\n\n"
"- 18H10’ Tin nóng 24h ( + QC, QB…)\n"
"- 18H30’ Thời sự Tp Cần Thơ /Dự báo thời tiết\n"
"- 19H00’ Điểm tin thị trường\n"
"- 19H03’ (QC,QB các chương trình của Đài …)\n"
"- 19H10’ Hộp thư truyền hình\n"
"- 19H20’ (QC,QB các chương trình của Đài …)\n"
"- 19H25’ Chuyện Bà Tám (313- Chưa vui tăng lương… )\n"
"- 19H35’ (QC,QB các chương trình của Đài …)\n"
"- 19H40’ Phim truyện Indonesia : MƯU KẾ TÌNH YÊU – Tập 48&49/90\n"
"- 21H30’ Món ngon mỗi ngày : LẨU GÀ ỚT HIỂM (pl)\n"
"- 21H35’ Phim truyện VN : BƯỚC QUA BÓNG TỐI –Tập 24/30\n"
"- 22H30’ Tin nóng 24h (pl) ( + QC, QB…)\n"
"- 22H50’ (QC,QB các chương trình của Đài …)\n"
"- 22H55’ Bản tin Thời sự TpCT \n"
"- 23H05’ Bản tin thế giới\n"
"- 23H15’ Bản tin tiếng Anh\n"
"- 23H25’ Phim tài liệu : GIẢI PHÁP MỀM CHỐNG SAT LỞ VÙNG BIỂN CÀ MAU\n"
"- 23H40’ Phim truyện HQ : BẢN LĨNH NÀNG DÂU – Tập 16/88 \n"
"PTV xh trở lại : \n"
" Chương trình truyền hình của Đài PT&TH Tp Cần Thơ đến đây là hết, \n"
"Hẹn gặp lại quí khán giả vào chương trình truyền hình sáng thứ ba.\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.