#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*"
Local $sString = "| Year | value |" & @CRLF & _
"| - - - | - - - |" & @CRLF & _
"| 1956 | 135436132 |" & @CRLF & _
"| 2001 | 86435233 |" & @CRLF & _
"| 2008 | 1368543 |" & @CRLF & _
"| 2077 | 168463213 |" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")